Personal Water Craft Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I Purchased a Used Kawasaki Stand Up. It has been Painted and there are no Markings on it. The guy I bought it from Claimed it was a 750 but the plastic Cover on the Carb says 650. This is the Hull Id Number is KAW661150L889. Can someone tell me what I have?
 

·
Read Only
Joined
·
5,059 Posts
If it's all original it's prob a 650. You would have to call Kawasaki and have them run the hin to find out which of the 3 89's it is. If you can get the numbers off the engine they can run that for you also, or you can just pull the head and mic the bore.
Post some pictures so we can take a look.
 

·
Registered
Joined
·
30 Posts
It's also not a 650 as they have a more compact hood area this at least looks like a 550 or 750, can't tell by looking unless you put a 550 next to a 750 then they stand out as the 750 is slightly longer.
A lot of parts are interchangeable on the Kawasaki Pole Skis .
Could be a 750 with a 650 engine ?
Or a 550 with a 650 engine or just a 650 cover as he couldn't get the right one.
You don't need to pull the engine apart to mic the bore, that's a silly answer lol, just get the engine number and if it doesn't say 750 in the number or if the Body number doesn't have 750 in the number then you will need to Google how Kawasaki labelled their 750's should only take a few minutes.

Remember that people lie and especially when they talk to other people that don't have a clue, did you buy the Ski from people ;)

I bought a 550 Pole Ski years ago and was told the motor was rebuilt and naturally assumed that rebuilt meant some new parts, instead they had put in two different sized pistons and no new parts at all, my fault for not getting them to start it as it felt like it had good compression, $250 later it ran like a champ, the battery was flat so it wouldn't kick over enough to start and I was in a bit of a hurry so took the chance.
I learnt after that not to trust people :)
I still got a pretty good deal but it was only after I rebuilt the engine properly :)
 
1 - 6 of 6 Posts
Top