Personal Water Craft Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi Everyone,

I have a 1989 Yamaha WR500 waverunner. I believe my CDI unit is bad so where can I buy a second hand CDI unit ? I don't want to buy a brand new one since my waverunner is old, it's not worthy of spending too much money on the new CDI.

THANKS.
Kevin

Please also respond to [email protected]
(I'm not sure how keep trach of this thread)
 

·
Registered
Joined
·
20 Posts
Ebay is the only place I have found Kevin. I am new to the forums and just purchased 2 WR500Qs. On the first day one of the CDI modules failed. I travel far from home with these so I just got a new one for $289. You're right, it's a bit silly to pay that much when I only paid $650 for the ski, but I need reliability and the ski is flawless otherwise.
 

·
Registered
Joined
·
21 Posts
Ebay is the only place I have found Kevin. I am new to the forums and just purchased 2 WR500Qs. On the first day one of the CDI modules failed. I travel far from home with these so I just got a new one for $289. You're right, it's a bit silly to pay that much when I only paid $650 for the ski, but I need reliability and the ski is flawless otherwise.
-------------------------------
i have copied and pasted this from my posts, read it please this works 100% and is a much cheaper way.

You can modify these easily and cheaply folks, as an ex electronics guy i have found the fix, the problem with most 500, 650 and some others is that the CDI box has a rev limiter, you can order a CDI through jaycar electronics $50 AUD, or you can order a high performance CDI off ebay.

The CDI off jaycar works like a dream, beware though the main diode coming off the charge coil may blow so replace with a 40volt 3 amp schotsky diode parallel with the 5804 diode.

Be warned though, this thing now flies but you need to limit the revs otherwise your head will blow.
 

·
Registered
Joined
·
20 Posts
My 2nd CDI went out last weekend. I found a 61X CDI locally from a 1996 Waveraider 701. It fired right up, but won't rev past idle, it just bogs. The connection was a perfect wire for wire so I tried to disable the REV limiter as shown in another thread, but still no go. Any ideas.
 

·
Registered
Joined
·
20 Posts
FYI, the 61X will not work, nor will a 62T. I tried everything and it won't rev with that CDI, something different about the signal from the engine. The 62T won't even fire. I purchased another 6K8-85540-11 and all is good again. Now both of my skis have a new one. We'll see how long they last.
 
1 - 9 of 9 Posts
Top