Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I hav a yamaha GP1200r 2001 and i had it owt a few weeks ago and i think i sucked sumthing up so pulled the pump apart and it was fine i put it pack together and was fne but before this i cud ride around on it all day and touch the cylinders and would b warm but when i started it with the flush kit the got hot where i could touch but not hold my hand there for to long any ideas ? is this normal hen on theflush kit and out the water or overheating it was only runnig for 3 mins max ? and also when running on the flush kit where should water cum from ie tell tail etc ?

Thanks

and also what is best stainless steel wear ring or a replacable one like in seadoos as i need a new one ? and what is best impellar make and pitch ?
 

·
Registered
Joined
·
323 Posts
Pull the hose off the back of the exhaust manifold (the main water inlet), blow through it and see if is blocked. You may have to pull the pump unit out and clean out the intake which is located in the pump vein on one side. The water outlets are on either side at the front inline with the hangers.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
i have blew down the pipes and othes and all flow fine but still gets realy hot after just a minitue of running ? :S:S:S:S
 

·
Registered
Joined
·
323 Posts
have you done exactly what i said in last post. ?? those skis have big water jackets and are very hard to get blocked. In fact i dont think i have ever seen a yam 1200 P/V motor with blocked water galleries so if you have, you must have run it up on the sand heaps.
 
1 - 4 of 4 Posts
Top