Personal Water Craft Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi! I purchased yesterday Yamaha GP800 99'

The problem is,it doesent want to start...i disconected the plugs,grounded them to head,it has spark while cranking...

Gasoline seems like it is going through the filter...but it doesent start...i poured gasoline directly into carburetors,nothing...i poured gasoline directly to combustion chamber...nothing

Compression tested,

Front cylinder(magneto) 90Psi
Rear cylinder (pto) 60 psi....

I suspect it is a non starter because of low compression,because spark and fuel is available...
What compression they should have stock?

I dont know much about ski,i see riva-yamaha trust cone,plastic impeller housing,ngk plug leads,ada adapters for cone filter,riva racing sponsons...

I would like fellow and more experienced members to give opinion on it...thank you very much in advance...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Compression tester that i bought is not an expensive one ,but used to give always good estimates...

Update: engine was full of some mayonnaise/water like gunk(is not winterizing fluid) and i think the piston rings have sticked to pistons.i put some more gasoline directly to the cylinders and cranked it out,now the compression is 125/125...i think it should be ok.

Engine started,but stutters little bit,maybe needs new fuel ,and carb rebuild kit/adjusting.


free image hosting
 

·
Registered
Joined
·
11 Posts
Even with that low of compression if that is what it actually is I’d think it would start. Charge battery..pull plugs and make sure they are dry and clean..spray some starter fluid in the cylinders but not much and try to start it…if it fires it’s a fuel issue..doubt the timing got off because then you’d have a real issue.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I posted this earlier yesterday,but maybe post is not yet approved because of the picture:

"Update: engine was full of some mayonnaise/water like gunk(is not winterizing fluid) and i think the piston rings have sticked to pistons.i put some more gasoline directly to the cylinders and cranked it out,now the compression is 125/125...i think it should be ok.

Engine started,but stutters little bit,maybe needs new fuel ,and carb rebuild kit/adjusting."
 
1 - 7 of 7 Posts
Top