kawasaki sc kill switch and lanyard not working - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-11-2018, 03:09 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 4
kawasaki sc kill switch and lanyard not working

Hi, '91 sc. motor continues to run when either (or both) the engine off button is pressed and the lanyard is removed. I checked the switches and they are fine. Checked all wiring down to the electrical box, fine. In the electrical box, there is a black ground wire from the 2 kill switches but it looks like it goes into the cdi . Please confirm where this wire goes and if it does go into the cdi, do I have to get a new cdi to get the thing to shut off? Thanks
bbar is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-12-2018, 06:22 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 5,022
Dock
There is a grounding point in the box, I believe it is by the cdi box and rectifier and that's actually where that ground should terminate. Parts diagram shows appx 3 grounds on that bolt. Going off other diagrams, the white wire goes straight to the cdi. The button grounds the white to kill the engine.
Just for shits and giggles, I would pull the stop button apart and clean the contacts. It is extremely common for them to corrode.
I would also check continuity from the bolt head to the contact inside the button.

Last edited by rodsatheart; 07-12-2018 at 06:53 AM.
rodsatheart is offline  
post #3 of 6 (permalink) Old 07-13-2018, 04:45 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 4
Thanks for response. the black and white wires from the switches definately go into the cdi. A black wire comes out of the cdi and joins 3 other black wires from other places on the rectifier bolts. Would the black wire that comes out of the cdi be the end of the line for the one from the switches that went in?
bbar is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-13-2018, 05:18 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 4
additional info: cleaned all of the previously mentioned ground wires and connections, no change. ski keeps running. When I unplug the white and black wires from the switches at the connector before the cdi and put an ohm meter across them and push the buttons, I get an increase in the ohms which I assume means the switches are activating. thanks
bbar is offline  
post #5 of 6 (permalink) Old 07-14-2018, 06:22 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 5,022
Dock
All the stop button is doing is grounding the white wire. If you take a piece of wire, attach it to a good engine ground, touch it to the white wire, it should kill the engine.
rodsatheart is offline  
post #6 of 6 (permalink) Old 07-16-2018, 08:37 AM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 4
Thanks for help. I grounded the white wire at the plug going into the cdi. It did kill the engine. Once I did that, the buttons started working again. Don't quite understand why, but all good now.
bbar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lanyard switch test nycdon73 Yamaha Jetski 8 01-21-2016 06:18 PM
650 SX Kill Button Not Working: Need Help jgnutz Kawasaki Jetski 0 04-07-2014 01:12 PM
Aftermarket Kill Switch barnbridge Kawasaki Jetski 7 07-22-2012 01:36 AM
I want to put a lanyard kill switch on a 750 sx. krk1984 Kawasaki Jetski 2 09-29-2008 10:49 AM
WR500 kill switch problems Cajun Yamaha Jetski 6 08-22-2007 05:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome