550 sx sudden power decrease in 2 days apart - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-27-2019, 08:28 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 4
550 sx sudden power decrease in 2 days apart

So, basically we did a full rebuilt on a 550 sx that have been sitting for 13 years on our garage, 2 days ago we went riding and it felt normal, idles agressive as always and rode quite well, but at the end of the afternoon the idle felt less agressive and it ran slower, basically it became less agressive at all , so today we went riding and from the beginning felt not as powerful or agressive as last time.
2 days ago we were running premium fuel and today we filled it with regular fuel, does it change anything ?
Also its having batteries problems, can it decrease the power or anything related?
Gabriel2603 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-28-2019, 05:02 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
If the battery is not staying charged, yes it will affect it. A bad battery can cause the system to work to hard. Might do a compression test to make sure nothing going on there, and did you clean the fuel system and rebuild the carb ?
rodsatheart is online now  
post #3 of 7 (permalink) Old 01-28-2019, 08:32 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 4
We did, full rebuilt and everything, the only initial issue was battery, first day ran perfectly, 2 days later felt different
Gabriel2603 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 01-30-2019, 04:53 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
Have you pulled the plugs to see what they look like ?
rodsatheart is online now  
post #5 of 7 (permalink) Old 01-30-2019, 07:21 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 4
We just rebuilt the whole things and placed new plugs, i'd say they are fine
Gabriel2603 is offline  
post #6 of 7 (permalink) Old 01-30-2019, 08:11 PM
Junior Member
 
Join Date: Nov 2018
Location: Boondall, Qld, Australia
Posts: 16
Did you run it in with sightly more oil then standard at first and take it easy for the first hour or so as the rings wear in, or did you just go flat out from the start and revved the crap out of it with no wear in period ?
Did you assemble the magneto correctly, tightened all the screws and bolts as the magneto does the timing and if it slips a little it will be firing incorrectly and one a two stroke that really effects it, also do you have a small air leak in the exhaust maybe ?
I had a 550SX and mine at one time went as though it was running out of fuel and I found it was a broken joiner on the power pipe.
So many things it can be when people do their own rebuilds as we have no clue if you even know which end of a screw driver to use, so giving advice on what could be wrong after a rebuild, it's more like what may not be wrong after amateurs rebuild a ski
Gardum is offline  
post #7 of 7 (permalink) Old 01-30-2019, 10:12 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 4
Its not our own build, 2 mechanics took it to their shop, and it was there for like 6 months, i would say all the exaust pipe and bolts are on well state, on the other hand, i didnt rode it at first, but i guess the guy first warmed it and then rode i'd say.
I kinda believe its a battery thing or the gasoline too, but we never know...
Gabriel2603 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
yamaha xlt 1200 sudden loss of power exjuno Yamaha Jetski 1 07-29-2014 02:05 PM
sudden loss of power jspang Yamaha Jetski 2 07-23-2014 05:50 PM
bought ski with engine apart what should I do first? tradewinz Sea-Doo Jetski 6 05-07-2014 02:32 PM
Mister---sudden death----sudden reserection bjstorm69 Polaris Jetski 0 07-04-2013 10:51 PM
Have pump torn apart - a couple questions hyunelan2 General PWC & Jetski Discussion 0 07-20-2006 09:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome