My JS550 wont run at full throttle - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-07-2011, 06:16 PM Thread Starter
Junior Member
 
Join Date: Apr 2011
Posts: 8
My JS550 wont run at full throttle

I have searched and found no answers so Im really hoping for help. My 89 js550 runs great!!! The only problem is that it only runs great out of water. In the water it will get to mid rpms, and when i make an attempt to plane (go WOT) it will slowly get on the plane and then shuts off. It always starts back up easily but when I start it back up it will just idle. I'll be WOT and it will just be holding an idle. A few minutes later it will repeat the process all over again. It act's like it is going to plan, but then shuts off. When it shuts off it sounds and feels like it would if you let go of the throttle. Even though you are holding WOT. It has fresh gas with good oil at 40:1. However on land it runs great. I have tuned the carb perfectly (imho) and i am confident it is not my tuning. It is a stock Js550 other than a pipe. I have taken off and cleared my cooling lines as well. The best way I can describe it when it gets on a plane is its hitting a rev limiter like a car. Basically stuttering. I disconnected the RPM limiter on the ski and the problem is still there. I have not checked compression but it always starts very strong and runs and sounds good out of the water. As i am new to jetski's im not sure on what is normal and what isnt. My exhaust is smoking dry out of the hull. Is it supposed to do this? Or is water supposed to come out with it? On land when it is hooked up to the hose water comes out of this. But I didnt notice water out of this in the water. Im thinking that may just be because im not able to run WOT and the engine isnt running fast enough to push water out of the water box. I have installed a new water box as well. My ski is also equipped with a primer. (trying to add as many details as possible.) So basicly im curious, what could be causing a ski to run good on land, but not reach its full rpms on the water. Thanks so much for the help.
DavisDreamer is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-08-2011, 10:54 AM
Senior Member
 
p10sdad's Avatar
 
Join Date: Mar 2011
Posts: 298
Just above idle water comes out. Are you far from the lake? I'm guessing you tuned your ski hooked up to the garden hose! Try re-jetting at the lake. Being hooked up to a hose, and being under a full load are very different. I had 90 do the same thing. Things to check, stator, timing, carb rebuild, exhaust leaks. I would put my choke a 1/4 on and that thing ran like a champ
p10sdad is offline  
post #3 of 4 (permalink) Old 07-01-2011, 02:31 PM
Member
 
Join Date: May 2009
Location: granite bay, ca
Posts: 51
Check compression the strap it to trailer and tune in water lik he said. Also check all ur cooling lines. Good luck
550subman is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-22-2017, 03:23 PM
Junior Member
 
Join Date: Aug 2017
Posts: 4
Did you ever figure this issue out?
Rielly101 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Twist Throttle instead of Finger Throttle KDog Yamaha Jetski 5 03-19-2015 07:04 PM
05 vx 110 won't run full speed hwhattt Yamaha Jetski 1 08-26-2011 09:35 AM
my superjet keeps hopping out of the water at full throttle and wont stay down??? adamjorgensen Yamaha Jetski 0 06-10-2010 05:19 PM
Polaris 780 wont go when given full throttle shawndak089 Polaris Jetski 5 07-23-2009 02:11 PM
1999 Seadoo XP won't run full speed halvors1 Sea-Doo Jetski 3 05-19-2009 05:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome