PWC Forum:  The best hang-out for Personal WaterCraft enthusiasts

-   Yamaha Jetski (https://www.pwcforum.com/yamaha-jetski/)
-   -   05 GPR 1300 Help?? (https://www.pwcforum.com/yamaha-jetski/72627-05-gpr-1300-help.html)

YamahaNewbie 03-17-2019 11:45 AM

05 GPR 1300 Help??
 
I recently inherited a 05 GPR 1300 with only 96 hours on it. When I first got it, i rode it for about 10 minutes on a lake with no known issues. I then took it to have it serviced with an inspection done. Compression was great and all cylinders, the ski was greased and lubed up for the season with the spark plugs being changed in addition. The d-plate was previously installed in addition to the CAT sensor and the CAT was removed. So all good things.

I took the ski out yesterday and drove it for about 30 minutes without issue when suddenly the warning light started flashing, I then drove it for about five more minutes to get it docked with the light flashing and cut the engine off. Waited about five minutes and then started her up and with no warning light flashing. I thenlet her run for about five minutes with no light activating.

I then took her out this morning and again she ran great for 30 minutes and then the warning light and beep came on this time. Then I noticed the engine light was flashing along with the exhaust overheat light as well. Rode her back to the dock which took about 10 minutes this time all the while listening to that annoying beeping. I then cut her off and let her rest for about five minutes. Started her up in the water and the codes, warning light and beeping were gone. I then got back on the ski and took her out for about five 10 minutes riding it hard with no issues.

What do I have here fellas?

rodsatheart 03-18-2019 06:15 AM

Sounds like a cooling issue, but could be a exhaust temp sensor also. This one here is right up Dave's alley.

YamahaNewbie 03-18-2019 10:46 AM

Let’s see what Dave has to say then 🙂

Dave in DE 03-19-2019 09:28 AM

Sounds like Rods hit the nail on the head.
Did you notice during the overheat times was there water coming from both left and right side pissers?... If not.
I'd check all your water lines for restrictions. Including the inlet screen in the side of the pump. (4 bolts on left side of the pump)
If they were working strong then I'd check out the temp switch. And there is still the possibility the exhaust water passages are restricted/clogged causing poor water flow.
Has this has always been a freshwater ski? Does it get regular flushing on the hose?

Dave in DE 03-19-2019 09:34 AM

If you need the temp sensor go through Yamaha or if you find it on eBay make sure it a Yamaha part not after market. I use Babbittsonline for parts. Especially electrical parts.

Dave in DE 03-19-2019 10:39 AM

52 Attachment(s)
After rereading your post.
Do you know from previous owner. Im assuming it's a family member, if there was a history of this issue?

YamahaNewbie 03-19-2019 11:24 AM

I appreciate all of the helpful words Dave, the ski was purchased from an Individual that routinely stated the ski never touched salt water. I did not notice any water coming from the front side pissers when the warning light along with the other two lights were flashing. I do every time I take her out flush her for about five minutes with a hose and while I just had Her serviced she received a salt away treatment which I’m sure you’re familiar with the product. I was leaning more towards the exhaust temp switch but I’m glad you pointed out the other alternatives as well.

Dave in DE 03-19-2019 12:17 PM

I'm kind of feeling it may be switch as well. But I'd check it all out to be safe. No need to smoke a good motor.
Where are you located?

Dave in DE 03-19-2019 12:42 PM

Just looked up exhaust temp sensor. $208. You'll want to check the system out first. There are ways to check the sensor but you'll need the manual for that. You should be able to find one on eBay in paper and downloadable.
Rods may know of another location to get. I'll leave him a message to get to you.

YamahaNewbie 03-19-2019 04:24 PM

Sounds good I’m located in South Carolina on the Atlantic coast, I found A new exhaust temp Sensor on eBay for around $140 that is Yamaha OEM. Definitely want to test the existing one before I blow more money a new one. But all in all I’m hoping it’s just the sensor. I mean I’m looking right at it as soon as I take the seat off and I shouldn’t be to hard to do myself I assume. Would def like to locate a manual for her so if your contact could hook me up with that it would be very much appreciated.


All times are GMT -5. The time now is 07:15 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome