PWC Forum:  The best hang-out for Personal WaterCraft enthusiasts

-   Yamaha Jetski (https://www.pwcforum.com/yamaha-jetski/)
-   -   2005 VX1100 won’t get up to speed (https://www.pwcforum.com/yamaha-jetski/72931-2005-vx1100-won-t-get-up.html)

gregdobbs 06-18-2019 12:08 AM

2005 VX1100 won’t get up to speed
 
I am having an acceleration issue and a top end speed issue. At around 8500 rpms it tops out at 45 mph. Normal top speed is 59. I accidentally left the tank just under half full with no stabilizer over the summer. I added 10 gallons last month which I thought would counter possible bad fuel. Could this be a cause of the lack of top end?

It’s running a little rough at idle as well.
Thoughts anyone? Thanks.

rodsatheart 06-18-2019 04:09 AM

Try running some injector cleaner through it and change the plugs.

gregdobbs 06-27-2019 12:01 PM

Had one fouled plug. Replaced them all and I am back to full power.

Dave in DE 06-27-2019 02:20 PM

Quote:

Originally Posted by gregdobbs (Post 7092381)
Had one fouled plug. Replaced them all and I am back to full power.

I would still run a can of good fuel system cleaner through it. Try a can of BG 44k. It's high end stuff and works great. Some dealer parts departments carry it if not you can buy online.
I wouldn't put it in though till you run the tank out. It would work best that way.


All times are GMT -5. The time now is 08:02 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome